Руководство по работе с пакетом 

динамического моделирования VisSim 3.0.


1. Основные принципы работы с пакетом.


1.1. Запуск и описание основного окна программы VisSim.


Запуск программы VisSim можно произвести через меню «Пуск» («Start») в Windows. Для этого следует щелкнуть левой кнопкой мыши на этой кнопке, затем выбрать пункт главного меню «Программы». Если на компьютере установлена, например, версия 3.0 (FAP) пакета VisSim, то, как правило, чтобы запустить основную программу, необходимо последовательно выбирать следующие пункты меню «Пуск» (начиная с самой кнопки «Пуск»):

Пуск -> Программы -> VisSim FAP - VisSim 3.0 -> VisSim 3.0 (FAP)

Щелчок по ярлыку VisSim 3.0 запускает программу на исполнение. 

Примечание: В дальнейшем под щелчком мыши подразумевается щелчок именно левой кнопкой мыши. Если требуется выбрать какой-либо пункт меню, то необходимо навести курсор мыши на этот пункт и щелкнуть левой кнопкой.


После загрузки на экране появляется окно программы, которое включает в себя основные элементы (начиная с самого верхнего, см. рис. 1.1.): 

- заголовок окна, в котором указано название программы «VisSim» и название текущей диаграммы. Первоначально никакой диаграммы в VisSim не загружено, поэтому можно видеть чистый лист, название которого по умолчанию - «Diagram1».

- строка меню, состоящего из пунктов «File», «Edit», «Simulate», «Blocks», «Comm», «Analyze», «View» и «Help» (описание пунктов меню приведено в п.2).

- панель инструментов. На это панели расположены кнопки, каждая из которых соответствует какому-либо действию. Например, первая кнопка создает новый пустой лист диаграммы, вторая - позволяет открыть уже имеющуюся на диске диаграмму и т.д. Все эти кнопки дублируют некоторые из команд основного меню и предназначены для обеспечения большего удобства работы с пакетом.

   На панели инструментов также располагаются некоторые палитры типовых блоков.

- дерево диаграммы, показывающее иерархическую структуру блоков диаграммы.

- окно диаграммы. В этом окне находится текущий лист диаграммы (первоначально он пуст). Линии прокрутки справа и внизу окна диаграммы позволяют перемещать видимую область листа для просмотра больших диаграмм. 
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Рис. 1.1. Окно основной программы VisSim 3.0.

- строка состояния. В этой, самой нижней строке экрана, отображается информация о текущем состоянии системы: 

Blks - указывает число функциональных блоков на диаграмме, 

Rng - начальный и конечный моменты времени расчета, 

Step - шаг по времени, 

Т(Time) - текущее время расчета (если диаграмма не запущена на выполнение, то время равно нулю). 

   Также в строке указывается метод интегрирования. Пакет VisSim позволяет просчитывать дифференциальные уравнения следующими методами: Euler - метод Эйлера, Trapezoidal - метод трапеций, RK2 - Рунге-Кутта 2-го порядка, RK4 - Рунге-Кутта 4-го порядка, Adaptive RK5 -адаптивный метод Рунге-Кутта 5-го порядка, Adaptive Bulirsh-Stoer и Backward Euler.
Замечание. Желательно, чтобы не иметь в дальнейшем проблем со шрифтами, сразу после загрузки программы изменить их кодировку. Для этого следует выбрать пункт «View -> Fonts…». Появившееся окно определяет шрифт, который используется по умолчанию (см. рис. 1.2.). Здесь можно выбрать тип шрифта, его начертание, размер, цвет и кодировку. По умолчанию установлен западноевропейский набор символов. Если на вновь созданной диаграмме будут расположены надписи на русском языке, то необходимо выбрать в качестве набора символов кириллицу.
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Рис. 1.2. Выбор шрифта.


1.2. Принципы построения и редактирования диаграмм.


Под диаграммой понимается набор функциональных блоков, соединенных между собой линиями связи и отображаемый в окне диаграммы VisSim. 


Палитры функциональных блоков находятся в меню «Blocks» и представляют собой достаточно большой набор основных элементов автоматики. Каждый из блоков моделирует динамические свойства некоторого соответствующего ему простого объекта. Размещая эти объекты на диаграмме и соединяя их функциональными связями, можно моделировать более сложные системы. 


Любая диаграмма может быть либо загружена с диска (если она была ранее создана и сохранена в виде файла), либо создана заново. Процесс создания диаграммы заключается в выборе мышью соответствующих блоков из палитр и размещении их на листе диаграммы с последующим их соединением связями. 


Для размещения какого-либо блока на диаграмме необходимо выполнить следующие действия мышью: щелкнуть на меню «Blocks», выбрать соответствующую палитру, выбрать соответствующий блок и щелкнуть на нем мышью. Если блок продублирован в виде соответствующей кнопки на панели инструментов, достаточно щелкнуть по ней мышью. 


После этого остается щелкнуть на том месте диаграммы, куда необходимо поместить блок. Сразу же блок появится на экране. 
 


Например, расположение на диаграмме усилительного блока (блок «gain») происходит в следующей последовательности: щелчок на пункте меню «Blocks» -> выбор палитры «Arithmetic» -> выбор пункта «gain» -> щелчок на пункте «gain» -> подведение курсора к тому месту диаграммы, где будет располагаться блок -> щелчок мыши размещает блок на диаграмме.


Все операции производятся левой кнопкой мыши. Правая кнопка в VisSim предназначена только для изменения свойств отдельных блоков. Если щелкнуть на каком-либо блоке правой кнопкой, то появится окно с его настройками. Например, окно настроек усилительного блока (блок «gain») содержит только одну настройку - коэффициент усиления. 
Вновь созданный блок содержит только настройки, принятые по умолчанию. Например коэффициент усиления усилительного блока по умолчанию равен 1.


Каждый блок изображается на диаграмме, как правило, в виде прямоугольника, внутри которого схематично изображено его функциональное назначение. С левой стороны блока находятся его входные сигналы (изображены в виде стрелок), с правой выходные. Количество входов и выходов у каждого блока различно и, как правило, неизменно.


Блоки можно перемещать на диаграмме для их наиболее удобного расположения. 

Примечание: Для этого необходимо нажать (не щелкнуть!) левую кнопку мыши на блоке, который следует переместить. Далее, не отрывая пальца от кнопки, переместить мышь в нужную точку. После отпускания кнопки мыши блок расположится в том месте, где был курсор.


Для одновременного перемещения группы блоков необходимо начала эту группу выделить.


Выделение блоков производится следующим образом. Мысленно нужно представить себе прямоугольник на экране, который бы окружал (или хотя бы задевал) только те блоки, которые следует выделить. Далее необходимо нажать левую кнопку мыши в левом верхнем углу этого прямоугольника и, не отпуская ее, начертить этот прямоугольник, проведя мышью с нажатой кнопкой в противоположный, правый нижний, угол. (Прямоугольник, как правило, отображается зеленым цветом). Как только кнопка мыши будет отпущена, блоки окажутся выделенными. (Блоки почернеют или инвертируют цвет). Далее с группой блоков можно оперировать как с единым блоком. Например, ее можно перемещать, удалять, копировать и объединять.


Для удаления блоков следует сначала выделить, как описано выше, блок (или блоки) и нажать на клавишу «Delete» клавиатуры.


Если на строящейся диаграмме должны иметь место несколько групп блоков, похожих по структуре и (или) составу (повторяющиеся элементы схемы), то значительно упростить процесс ее создания поможет копирование блоков. Для копирования необходимо выделить копируемую группу блоков и нажать комбинацию клавиш «Ctrl+C» (то есть, нажать клавишу «Ctrl» и, удерживая ее в нажатом положении, нажать «С»). Группа блоков скопируется в буфер Windows. Далее нажимается комбинация «Ctrl+V» и мышью указывается место, куда будет помещена скопированная группа. Щелчок мыши располагает группу на диаграмме. Если необходимо разместить третью, четвертую и т.д. группы, то повторные нажатия «Ctrl+V» и щелчки мыши позволят это сделать.


Объединение блоков применяется для визуального упрощения диаграммы. Например, если диаграмму можно разбить на несколько структурно отдельных объектов (например, модель технологического объекта, модель регулятора и т.д.) и при этом структура диаграммы достаточно сложна, то каждую группу блоков можно объединить в единый блок. Для этого необходимо выделить группу блоков, войти в меню «Edit» и щелкнуть на пункте «Create Compound Block». В появившемся окне следует ввести название создаваемого объекта и нажать кнопку «ОК». Сразу же группа блоков на диаграмме будет заменена одним блоком зеленого цвета. Если войти в этот блок (щелчком правой кнопки мыши или двойным щелчком левой кнопки), то можно увидеть первоначально располагавшиеся на диаграмме блоки. Количество вложений блоков не ограничено.


Создание линий связи производится левой кнопкой мыши. Чтобы соединить два расположенных на диаграмме блока необходимо подвести мышь к выходу одного блока. Как только курсор превратиться в стрелку вида (, нажать левую кнопку. Далее, удерживая кнопку нажатой, подвести мышь ко входу второго блока. В процессе движения мыши за ней будет тянуться линия связи. Как только курсор достигнет входа, отпустить кнопку. Практика показывает, что линии удобнее проводить в обратном порядке


Для разрыва линий связи необходимо навести мышь на начало (или конец) линии, нажать левую кнопку, немного отодвинуть мышь от блока и отпустить кнопку. Линия должна исчезнуть.


Иногда (например, при изображении линий обратной связи) требуется развернуть блок (блоки), то есть расположить его так, чтобы его входы находились с правой стороны, а выходы - с левой. Для этого необходимо выделить блок (блоки) и нажать комбинацию «Ctrl+(» или «Ctrl+(» или выбрать в пункт «Flip Horizontal» (в версии 2.0 - «Rotate 180») в меню «Edit».


1.3. Сохранение диаграммы на диске.


Созданную или отредактированную диаграмму можно сохранить на диске. по команде меню «File -> Save». Этому пункту соответствует кнопка «Save» на панели инструментов (см. рис. 1.3., 3-я кнопка). Щелчок мышью по этой кнопке будет иметь тот же эффект. 


Если требуется сохранить диаграмму под каким-либо новым именем, то нужно выбрать пункт «Save as…» того же меню «File». В открывшемся окне нужно набрать имя диаграммы. Можно также указать место сохранения диаграммы на диске. После того, как все сделано, нажать кнопку «ОК». Диаграмма сохранится на диске в виде файла с расширением .vsm.
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Рис. 1.3. Панель инструментов.


1.4. Открытие диаграммы.


Чтобы открыть диаграмму, ранее сохраненную на диске, необходимо выбрать пункт меню «File -> Open…» или нажать на кнопку «Open» панели инструментов (см. рис. 1.3., 2‑я кнопка). При этом появится окно, отображающее содержимое диска, в котором нужно найти файл, выделить его щелчком мыши и нажать кнопку «ОК». 


После этого VisSim выдаст окно, в котором спрашивается, сохранять ли изменения сделанные в уже открытой диаграмме. Если никаких важных изменений не было сделано, то нужно нажать кнопку «Cancel» («Отмена»), в противном случае - «ОК». Сразу после этого имеющаяся диаграмма на экране будет заменена на новую.


1.5. Создание новой диаграммы.


Для создания новой диаграммы выбирается пункт меню «File -> New» или нажимается кнопка «New» (см. рис. 1.3., 1-я кнопка). После щелчка мыши VisSim выдаст окно, спрашивающее о том, сохранять или не сохранять сделанные изменения (см. п. 1.4.).


1.6. Печать диаграммы.


1.6.1 Настройка печати.


Перед печатью необходимо настроить параметры страницы, то есть задать ее размер, поля и расположение (горизонтальное или вертикальное). Для этого  выбирается пункт меню «File -> Page setup…». В открывшемся меню указываются следующие параметры:

- размеры полей: Right - правое поле, Left - левое, Top - верхнее, Bottom - нижнее. Для изменения значений полей следует щелкнуть на соответствующем белом поле и ввести значение.

- расположение страницы (поле Orientation): Portrait - вертикальное, Landscape - горизонтальное.

- заголовок страницы (поле Header) и нижний колонтитул (Footer).

- размер (Size) и источник бумаги (Source).

- если отметить галочкой пункт «Fit to page» (щелчком в квадратном поле слева от пункта), то при печати масштаб диаграммы будет подобран под размеры листа.


После того как установлены все настройки необходимо нажать «ОК».  


Нажатие на кнопку «Print…» позволяет выбрать принтер, на котором будет печататься диаграмма.
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Рис. 1.4. Окно параметров печати.
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Рис. 1.5. Окно печати.


1.6.2 Предварительный просмотр.


Если все настройки печати установлены правильно, то перед печатью диаграммы желательно просмотреть, как она будет выглядеть на бумаге. Для этого используется пункт «File -> Print Preview…». Сразу после щелчка на нем появляется изображение страницы. 


1.6.3 Вывод на печать.


Для окончательной печати текущей диаграммы выбирается пункт меню «File -> Print…». В появившемся окне можно указать настройки, которые будут действовать только в данном сеансе печати:

- в настройке «Print Quality» можно указать качество печати (для современных струйных и лазерных принтеров это не существенно). Для этого нужно щелкнуть на небольшой кнопке с треугольной стрелкой справа от значения настройки и в выпавшем списке щелчком мыши указать нужное качество. Качество указано в dpi (чем больше dpi, тем четче изображение).

- если требуется напечатать несколько копий диаграммы, то число копий указывается в пункте «Copies».
- параметр «Print to File» позволяет выводит диаграмму не на принтер, а в файл для последующей печати, например, на другом компьютере.

- параметр «Fit to Page» позволяет уместить диаграмму в одну страницу.


Если нажать кнопку «Setup», то появляется окно настроек принтера, в котором можно указать размер бумаги, ориентацию, текущий принтер и т.д.


После изменения необходимых настроек следует нажать кнопку «ОК», в результате чего диаграмма будет послана на печать. Если нажать «Cancel», то печать будет отменена.


2. Основное меню VisSim.
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2.1. Пункт File.

Рис. 2.1.

New - создание новой диаграммы,

Open - открытие диаграммы,

Save - сохранение на диске,

Save as… - сохранение на диске по каким-либо новым именем,

Diagram Information… - выдает окно с информацией о текущей диаграмме: Заголовок, автор, количество блоков и др.

Page Setup… - поля страницы,

Print… - печать диаграммы,

Printer Setup… - вызывает окно настроек драйвера принтера,

Printer Preview… - предварительный просмотр диаграммы перед печатью,

Real Time Config - изменение настроек драйвера реального времени,

Exit - выход из программы.


Далее в меню идет список диаграмм, которые были открыты недавно. Щелчок по каждой из них вызывает их на экран.


2.2. Пункт Edit.

Undo - отмена последнего произведенного действия,

Cut - вырезание блока или группы блоков (блоки удаляются с диаграммы и помещаются в буфер),

Copy - копирование блоков в буфер (блоки не удаляются с листа),

Paste - вставка блоков из буфера,

Clear - удаление блоков (в отличие от «Cut» не помещает блоки в буфер),

Flip Horizontal - разворот блока на 180(,

Create Compound Block - объединение группы блоков в единый блок,

Dissolve Compound Block - действие, обратное «Create Compound Block»,

Find…  - поиск переменной на диаграмме (в появляющемся окне необходимо ввести имя переменной, т.е. имя блока типа variable; после нажатия на «ОК» соответствующий блок будет выделен),
Replace… - поиск с заменой,

[image: image8.png]———

View Help
Eonts
Colors.

=,

Block Labels
Connector Labels
Disply o=
Data Tupes

v Presentation bods.

Control Panel
v Status Bar
ToolBar.




Block Properties… - изменение настроек какого-либо блока (после выбора этого пункта курсор мыши превращается в крест; если этот крест навести на какой-либо блок и нажать левую кнопку, то появится окно со списком настроек этого блока; команда аналогична нажатию правой кнопки мыши на блоке),

Рис. 2.2.

Add Connector - добавление еще одного входа (или выхода) к какому-либо блоку (после выбора курсор мыши превращается в крест, которым нужно указать на нужный блок и щелкнуть левой кнопкой; если функция блока позволяет это сделать, то у него появится новый вход или выход),

Remove Connector - команда, противоположная «Add Connector» (курсор также превращается в крест, которым нужно указать на блок с удаляемым входом)
Repaint Screen - перерисовка экрана (позволяет удалить графический «мусор», иногда появляющийся на диаграмме),

Preferences… - настройка внешнего вида окна программы (показывать ли линии прокрутки, привязывать ли блоки к сетке и т.д.),

Toolbar… - настройка панели инструментов (вызывается окно, в котором можно настроить несколько дополнительных кнопок панели, что позволяет облегчить и ускорить процесс создания диаграмм).
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2.3. Пункт Simulate.

Рис. 2.3.


Пункт содержит команды и настройки, используемые при расчете:

Go - запуск модели на исполнение (аналогично нажатию на кнопку с зеленой стрелкой на панели задач),

Stop - приостановить процесс расчета,

Single Step - выполнить один шаг расчета,

Continue - продолжить приостановленный расчет,

Reset - сброс результатов,

Simulation Properties… - выводит окно с настройками расчета. В окне можно задать следующие параметры:



На закладке Range:
Start - начальное значение времени,

Frequency - частота выполнения шагов расчета,

End - конечное значение времени.

На закладке Integration Method - алгоритм интегрирования дифференциальных уравнений. В этой настройке нужно мышью щелкнуть на нужном алгоритме. Методы интегрирования перечислены в п. 1.1.
На закладке Defaults - настройки, принимаемые по умолчанию для вновь создаваемых диаграмм (Range Start, Frequency, End, Integration Method, Max Plotted Points - число выводимых на график точек).

Optimization Properties… настройки, используемые в процессе оптимизации (метод, число итераций, погрешность)

2.4. Пункт Blocks.


Пункт содержит палитры функциональных блоков. Чтобы выбрать какой-либо блок, необходимо войти в это меню, найти нужный блок в какой-либо палитре и щелкнуть на нем. После этого можно щелчком указать на его место на диаграмме. Подробнее о палитрах см. п. 3.


2.5. Пункт Analyze.


Пункт содержит команды, используемые при анализе сформированных систем: определение передаточных функций систем, полюсов (корней характеристических полиномов), нулей функций, частотных характеристик (АЧХ и ФЧХ), устойчивости по Найквисту и др. Подробнее см. п. 4.
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2.6. Пункт View.

Рис. 2.4.


В этом пункте находятся настройки внешнего вида программы и диаграмм:

Fonts… - настройка используемого на диаграмме шрифта (размер, вид, кодировка и цвет).

В поле «Шрифт» можно выбрать вид шрифта щелчком левой кнопки мыши. В поле «Начертание» - тип начертания: обычный, курсив, полужирный, полужирный курсив. 

Также можно выбрать размер, цвет и набор символов. Набор символов должен быть установлен как «Кириллица».

Colors… - настройка цветовой гаммы внешнего вида программы (цвета надписей, фона и др.),

Presentation Mode - режим презентации (более нагляден),

Display Mode - если возле него стоит галочка, то на диаграмме все линии связи делаются невидимыми,

Block Labels и Connector Labels позволяют разрешать или запрещать отображение подписей к блокам и линиям связи.

Status Bar - отображает или запрещает отображение строки состояния внизу окна,

ToolBar - отображает или запрещает отображение панели инструментов.
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2.7. Пункт Help.

Рис. 2.5.


В этом пункте выводится помощь по программе:

Contents - содержание,

Search… - поиск,

Wiring - информация о работе с функциональными связями,
Simulating - информация о моделировании динамики,
Using Help - использование помощи,

About VisSim - информация о версии программы и др.


3. Функциональные блоки VisSim.


В данном разделе функциональные блоки упорядочены по палитрам. В Приложении 1 приведен перечень блоков по алфавиту.

Animation – палитра блоков анимации:

animate

блок анимации

lineDraw

Annotation – пояснения с диаграмме

bezel

картинка из файла для вставки на лист диаграммы

comment

пояснение на диаграмме (несколько строк)

date

вставка текущей даты

index

label

комментарий (одна строка)

scalarToVec
перевод скалярной величины в векторный вид

vecToScalar
перевод секторной величины в скалярный вид

variable

переменная (применение переменных позволяет уменьшить загроможденность диаграммы линиями связи)

wirePositioner 
позиционер для формирования направления линий связи

Arithmetic – арифметические функции

* (multiply)

умножение двух сигналов (имеет два входа и один выход)

-X (negate)

инверсия знака

/ (divide)

деление

abs

модуль

gain

блок усиления сигнала (коэффициент усиления)

pow

sign

знак сигнала (+ или -)

summingJunction
сумматор


Boolean – логические функции

<


меньше

<=

меньше или равно

==

равенство

!=


не равно

>


больше

>=

больше или равно

and

И (логическая конъюнкция)

not

НЕ (логическое отрицание)

or


ИЛИ (логическая дизъюнкция)

xor

отрицание ИЛИ (XOR)

DDE – блоки для организации обмена между программами

DDE

блок обмена данными с другой программой 

DDEreceive

блок приема данных из другой программы

DDEsend

блок отсылки данных в другую программу

Integration – блоки интегрирования

integrator

интегрирующее звено

limitedIntegrator
ограниченный интегратор (имеет максимальное и минимальное значения выходного сигнала)

resetIntegrator
сброс интегратора

Linear System – линейные системы

stateSpace

пространство состояний
transferFunction
передаточная функция

Nonlinear – нелинейные системы

case

оператор варианта (имеет несколько входов плюс вход case, определяющий какой из входных сигналов подавать на выход)

crossDetect
реле, определяющее сигналом какого-либо уровня

deadband
реле с зоной нечувствительности

int

целая часть числа

limit

ограничитель сигнала

map

max

определение максимального значения сигнала

merge

min

определение минимального значения сигнала

quantize
дискретизатор

relay

реле (двух-) трехпозиционное с зоной нечувствительности

sampleHold
«замораживатель» выходного сигнала (имеет два входа: х и b, при подаче на вход b сигнала на выходе блока устанавливается постоянный сигнал, равный мгновенному значению сигнала х).

Optimization – оптимизация систем

constraint

cost

стоимость (для анализа)

globalConstraint

parameterUnknown

unknown

Random Generator – генераторы случайных сигналов
gaussian

генератор случайно сигнала по Гауссу 

uniform

Real Time – функции реального времени

rt-DataIn

rt-DataOut

Signal Consumer – блоки для отображения сигналов
display

индикатор цифровой
error

export

histogram

гистограмма
light

лампочка (один вход)

meter

стрелочный индикатор

plot

графики (выводит одновременно до 4-х графиков разными цветами)

stop

stripChart

полосатая диаграмма

Signal Producer – генераторы сигналов

button

кнопка (один выход)

const

константа

import

получение данных из файла

parabola

параболическое воздействие

pulseTrain

импульсное воздействие

ramp

линейное воздействие

realTime

sinusoid

синусоидальный сигнал

slider

ползунок (для генерации входных сигналов)

step

Time Delay – запаздывания

timeDelay
запаздывание (два входа: задерживаемый сигнал и величина задержки)
unitDelay

Transcendental – тригонометрические функции

acos

арккосинус

asin

арксинус

atan2

арктангенс

bessel

бессель

cos

косинус

cosh

гиперкосинус

exp

экспонента

log10

десятичный логарифм

ln


натуральный логарифм

sin

синус

sinh

гиперсинус

sqrt

корень

tan

тангенс

tanh

гипертангенс

UserFunction

функция, определенная пользователем 

NeuralNet

блок нейронной сети


4. Примеры простых проектов.


4.1. Построение переходной кривой.

Задание. Требуется построить переходную кривую объекта, заданного передаточной функцией:

W(s) = 
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.

Решение. Для построения переходной кривой создается схема, представленная на рис. 4.1.
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Рис. 4.1. Построение переходной кривой.


Для этого сначала из палитры «Signal Producer» выбирается блок «const» (по умолчанию его значение равно 1). Затем из палитры «Linear System» блок «transferFunction». После того, как блок расположен на листе диаграммы щелчком правой кнопки мыши вызывается окно настроек этого блока (см. рис. 4.2.) и устанавливаются соответствующие значения. 


Последний блок - блок графиков «plot» из палитры «Signal Consumer».


Расположенные блоки соединяются линиями функциональных связей. В настройках моделирования «Simulate -> Simulation Properties…» устанавливается время начала, конца моделирования и частота (соответственно: Start = 0, End = 20, Frequency = 5). Модель запускается на выполнение (командой «Simulation -> Go» или нажатием клавиши F5 клавиатуры или нажатием кнопки Go панели инструментов). Результат представлен на рис. 4.1.


Для распечатки переходных кривых на принтере следует увеличить окно графиков «plot» во весь экран и дать команду «File -> Print…» или нажать на кнопку «Print» панели инструментов.
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Рис. 4.2.


4.2. Моделирование одноконтурной АСР.

Задание. Построить модель одноконтурной АСР с объектом, заданным передаточной функцией вида

W(s) = 
[image: image2.wmf]1

s

3

s

4

1

s

5

2

2

+

+

+

е-5s.

и ПИ-регулятором с настройками К0 = 0,08 и К1 = 0,1. 


Построить переходные характеристики по заданию и по ошибке.
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Решение. Строится модель, представленная на рис. 4.3.

Рис. 4.3.


Для моделирования объекта управления были использованы блоки передаточной функции (transferFunction), запаздывания (timeDelay) и константы (const).


Сигнал задания определяется в блоке константы (const). Выходные сигналы регистрируются в блоке графика (plot).


Настройки ПИ-регулятора задаются усилительными блоками (gain). Также в модели регулятора использован интегратор (integrator) и сумматор (summingJunction).


Обратная связь реализована с помощью формирователя связи (wirePositioner) и сумматора (summingJunction). По умолчанию все сигналы, поступающие на вход сумматора, берутся с положительными знаками. Для смены знака на противоположный (например, для организации отрицательной обратной связи) необходимо нажать клавишу «Ctrl» и, удерживая ее в нажатом положении, щелкнуть правой кнопкой мыши по соответствующему входу.


После расположения блоков на диаграмме, соединения их линиями связи и настройки диаграмма запускается на исполнение (см. рис. 4.3.).
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